Обновление php до 5.4 на ubuntu 12.04

Дата Автор adminОставить комментарий

Потребовалось обновить php до 5.4 на сервере с ubuntu 12.04 LTS и ISPManager. Первым делом остановил работу web-сервера nginx, так как после удаления старой версии php будет отдаваться исходный код страницы, что очень небезопасно! Обращаю ваше пристальное внимание, что если у вас открыт 81 порт, на котором работает по-умолчанию apache, установленный ISPManager, то нужно остановить… Читать далее Обновление php до 5.4 на ubuntu 12.04

И снова про обновление php до 5.2.17 на CentOS 5

Дата Автор adminОставить комментарий

Некоторое время назад писал статейку здесь, на блоге, как обновить php, но все течет и изменяется, приходится вносить коррективы и мне. Сейчас при обновлении php при подключенном репозитории atomic командой # yum update php система пытается обновить php до 5.3 Мне php 5.3 не нужно, хочу 5.2, поэтому я обновляю следующим образом..

функция imagerotate в PHP на Debian

Дата Автор admin2 комментария

Недавно попался 🙂 мне сервер с Debian Lenny, на котором нужно было настроить библиотеку gd для php5 Панель ISPManager ее устанавливает самостоятельно. Установил через панель, перезапустил апач — не работает.  Проверил — библиотека установилась, в списке php -m есть.. Оказывается, gd.so в Debian не содержит часть функций, в частности — imagerotate();